]> Pileus Git - ~andy/sunrise/blob - x11-plugins/pidgin-window_merge/pidgin-window_merge-0.2_p20120420.ebuild
ef949c4534f33b632478bd7915f5e683dd8989b6
[~andy/sunrise] / x11-plugins / pidgin-window_merge / pidgin-window_merge-0.2_p20120420.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6 inherit autotools
7
8 DESCRIPTION="A Pidgin plugin that merges the Buddy List window with a conversation window"
9 HOMEPAGE="https://github.com/dm0-/window_merge"
10 COMMIT="cf1dba5ff3b1006552a7a779b3bf9acfd56e9e82"
11 SRC_URI="http://github.com/dm0-/${PN#pidgin-}/tarball/${COMMIT} -> ${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE=""
17
18 RDEPEND="dev-libs/glib:2
19         net-im/pidgin[gtk]"
20 DEPEND="${RDEPEND}
21         dev-util/pkgconfig"
22
23 S="${WORKDIR}"/dm0--${PN#pidgin-}-${COMMIT:0:7}
24 src_prepare(){
25         sed -e "/ACLOCAL_AMFLAGS/d" -i Makefile.am || die
26         eautoreconf
27 }
28
29 pkg_postinst(){
30         ewarn "This plugin and infopane plugin (purple-plugin_pack) activated"
31         ewarn "at the same time cause a segfault in pidgin"
32         ewarn "see https://github.com/dm0-/window_merge/issues/4"
33 }