]> Pileus Git - ~andy/sunrise/blob - x11-plugins/pidgin-embeddedvideo/pidgin-embeddedvideo-1.1.2.ebuild
0353ce7b3b67a7bdad44195dd63df58dade9c630
[~andy/sunrise] / x11-plugins / pidgin-embeddedvideo / pidgin-embeddedvideo-1.1.2.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit versionator
8
9 MY_P=${PN}-$(replace_version_separator 2 '-')
10
11 DESCRIPTION="Pidgin plugin for sharing and viewing links to videos"
12 HOMEPAGE="http://code.google.com/p/pidgin-embeddedvideo/"
13 SRC_URI="http://pidgin-embeddedvideo.googlecode.com/files/${MY_P}.tar.gz"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 DEPEND="net-im/pidgin[gtk]
21         >=net-libs/webkit-gtk-1.1.12
22         net-misc/curl"
23 RDEPEND="${DEPEND}"
24
25 S=${WORKDIR}/${PN}
26
27 src_compile() {
28         emake -j1 || die "make fail"
29 }
30
31 src_install() {
32         emake install DESTDIR="${D}" || die "install fail"
33         dodoc AUTHORS ChangeLog || die "doc install fail"
34 }