]> Pileus Git - ~andy/sunrise/blob - x11-misc/sw-notify-send/sw-notify-send-0.1.ebuild
x11-misc/sw-notify-send: Update HOMEPAGE & SRC_URI (once again).
[~andy/sunrise] / x11-misc / sw-notify-send / sw-notify-send-0.1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit toolchain-funcs
6
7 DESCRIPTION="A system-wide notification wrapper for notify-send"
8 HOMEPAGE="http://github.com/mgorny/sw-notify-send/"
9 SRC_URI="http://github.com/downloads/mgorny/${PN}/${P}.c.bz2"
10
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~amd64"
14 IUSE=""
15
16 DEPEND="sys-process/procps"
17 RDEPEND="${DEPEND}"
18
19 # The lack of x11-libs/libnotify RDEPEND is intentional. The tool supports
20 # calling 'notify-send' from within a chroot running libnotify-enabled system
21 # where the host system is libnotify-free. Not to mention that running
22 # a libnotify notification daemon implies having libnotify installed.
23
24 src_compile() {
25         tc-export CC
26         emake LDLIBS=-lproc ${P} || die
27 }
28
29 src_install() {
30         newbin ${P} ${PN} || die
31 }