]> Pileus Git - ~andy/sunrise/blob - x11-misc/spacefm-httpshare-plugin/spacefm-httpshare-plugin-0.6.ebuild
x11-misc/spacefm-httpshare-plugin: drop empty einfo lines
[~andy/sunrise] / x11-misc / spacefm-httpshare-plugin / spacefm-httpshare-plugin-0.6.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 DESCRIPTION="Plugin to quickly share files/folders via http server"
8 HOMEPAGE="http://code.google.com/p/bashscripts/source/browse/trunk/spacefm-plugin/share-via-http-server/share-via-http-server"
9 SRC_URI="http://bashscripts.googlecode.com/files/Share_v${PV}.spacefm-plugin.tar.gz"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 RDEPEND="dev-lang/python
17         x11-misc/spacefm"
18
19 S=${WORKDIR}
20
21 src_install() {
22         find -name COPYING -delete
23         insinto /usr/share/spacefm/plugins/httpshare
24         doins -r cstm_* plugin
25         insinto /usr/share/spacefm/plugin-files
26         doins "${DISTDIR}"/Share_v${PV}.spacefm-plugin.tar.gz
27
28         cd "${D}"
29         find . -name "exec.sh" -exec fperms +x '{}' + || die
30 }
31
32 pkg_postinst() {
33         einfo "You might need to restart spacefm for the changes to take effect."
34         elog "If you want to add a plugin to a different menu via design-mode"
35         elog "use the plugin-files from '/usr/share/spacefm/plugin-files'."
36 }
37
38 pkg_postrm() {
39         elog "If you have copied the plugin to a different menu using the"
40         elog "design mode you might want to remove it from there as well."
41 }