]> Pileus Git - ~andy/sunrise/blob - x11-misc/marchfluxmenu/marchfluxmenu-1.2.ebuild
b6a8edc27c2e16d066693f0c3490eb71d39ec71c
[~andy/sunrise] / x11-misc / marchfluxmenu / marchfluxmenu-1.2.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils python multilib
6
7 MY_PN="mfm"
8 MY_P="${MY_PN}-${PV}"
9 DESCRIPTION="An attempt to have the fluxbox menu emulate Gnome (or XFCE) menu, in both looks and functionality."
10 HOMEPAGE="http://code.google.com/p/marchfluxmenu/"
11 SRC_URI="http://marchfluxmenu.googlecode.com/files/${MY_P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND="dev-lang/python"
19 RDEPEND="${DEPEND}"
20
21 S="${WORKDIR}/${PN}"
22
23 src_unpack() {
24         unpack ${A}
25         cd "${S}"
26         epatch "${FILESDIR}"/${P}-gentoo.patch
27         python_version
28         sed -i -e "s:@@PYDIR@@:/usr/$(get_libdir)/python${PYVER}/site-packages:g" \
29                 installer mfmdaemon || die "failed to fix paths"
30 }
31
32 src_compile() {
33         einfo "Nothing to compile, installing..."
34 }
35
36 src_install() {
37         dodoc README mfmdaemon
38
39         insinto /usr/share/${PN}
40         doins -r icons
41
42         newbin installer ${PN}
43         rm -rf COPYING README icons installer main.pyc mfmdaemon
44
45         python_version
46         insinto /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
47         doins *
48 }
49
50 pkg_postinst() {
51         python_version
52         python_mod_optimize "${ROOT}"usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
53
54         elog "Now just run ${PN} as user to generate your fluxbox menu."
55         elog "See README in /usr/share/doc/${PF} for more information on usage."
56 }
57
58 pkg_postrm() {
59         python_mod_cleanup
60 }