]> Pileus Git - ~andy/sunrise/blob - x11-misc/kxstitch/kxstitch-0.8.ebuild
sunrise/app-portage/elog-list/elog-list-0.0.6.ebuild: change headers to make repoman...
[~andy/sunrise] / x11-misc / kxstitch / kxstitch-0.8.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils kde
6
7 DESCRIPTION="A program to create cross stitch patterns and charts"
8 HOMEPAGE="http://kxstitch.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="imagemagick scanner"
15
16 DEPEND="imagemagick? ( media-gfx/imagemagick )
17         scanner? ( media-gfx/sane-backends )"
18 RDEPEND="${DEPEND}"
19
20 pkg_setup() {
21         if use imagemagick && built_with_use media-gfx/imagemagick nocxx ; then
22                 eerror "Building kxstitch requires imagemagcik built without"
23                 eerror "the nocxx use flag to build magick++ (the C++ API)."
24                 eerror "Please re-emerge imagemagick with this use flag disabled."
25                 die "imagemagick missing magick++"
26         fi
27 }