]> Pileus Git - ~andy/sunrise/blob - x11-misc/gxneur/gxneur-0.9.7.ebuild
d3091b79746bf0d151658d2753370f31a59fc5a7
[~andy/sunrise] / x11-misc / gxneur / gxneur-0.9.7.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils autotools versionator
8
9 DESCRIPTION="GTK based GUI for xneur"
10 HOMEPAGE="http://www.xneur.ru/"
11 SRC_URI="http://dists.xneur.ru/release-${PV}/tgz/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="nls"
17
18 RDEPEND=">=x11-misc/xneur-$(get_version_component_range 1-2)
19          >=x11-libs/gtk+-2.0.0
20          >=sys-devel/gettext-0.16.1
21          >=gnome-base/libglade-2.6.0"
22 DEPEND="${RDEPEND}
23         >=dev-util/pkgconfig-0.20"
24
25 src_prepare() {
26         rm ltmain.sh aclocal.m4 m4/{lt~obsolete,ltoptions,ltsugar,ltversion,libtool}.m4
27         sed -i "s/-Werror -g0//" configure.in || die
28         eautoreconf
29 }
30
31 src_configure() {
32         econf $(use_enable nls)
33 }
34
35 src_install() {
36         emake install DESTDIR="${D}" || die
37         dodoc AUTHORS ChangeLog NEWS || die
38         doicon pixmaps/gxneur.png
39         make_desktop_entry "${PN}" "${PN}" ${PN} "GTK;Gnome;Utility;TrayIcon"
40 }