]> Pileus Git - ~andy/sunrise/blob - www-servers/webcit/webcit-7.85.ebuild
dev-libs/libcitadel: Fixed scrambled Changelog entry
[~andy/sunrise] / www-servers / webcit / webcit-7.85.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 inherit eutils
7
8 DESCRIPTION="Modern AJAX-style web interface for Citadel"
9 HOMEPAGE="http://www.citadel.org/"
10 SRC_URI="http://easyinstall.citadel.org/${P}.tar.gz"
11
12 LICENSE="GPL-2 MIT LGPL-3 LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="ssl"
16
17 DEPEND=">=dev-libs/libical-0.43
18         >=dev-libs/libcitadel-${PV}
19         ssl? ( >=dev-libs/openssl-0.9.6 )"
20 RDEPEND="${DEPEND}"
21
22 WWWDIR="/usr/share/citadel-webcit"
23
24 pkg_setup() {
25         #Homedir needs to be the same as --with-datadir
26         einfo "Adding Citadel User/Group"
27         enewgroup webcit
28         enewuser webcit -1 -1 ${WWWDIR} webcit
29 }
30
31 src_configure() {
32         econf \
33                 $(use_with ssl) \
34                 --with-libical \
35                 --without-newt \
36                 --prefix=/usr/sbin/ \
37                 --with-wwwdir="${WWWDIR}" \
38                 --with-localedir=/usr/share/ \
39                 --with-editordir=/usr/share/citadel-webcit/tiny_mce/ \
40                 --with-rundir=/var/run/citadel \
41                 --with-ssldir=/etc/ssl/webcit/ \
42                 --with-datadir=/var/run/citadel
43 }
44
45 src_install() {
46         emake DESTDIR="${D}" install || die "make install failed"
47         newinitd "${FILESDIR}"/webcit.init.d webcit || die "Installing initscript failed"
48         newconfd "${FILESDIR}"/webcit.conf.d webcit || die "Installing conf for initscript failed"
49
50         ##House cleaning...
51         #We don't use Webcit's setup program
52         #Settings are in /etc/conf.d/webcit
53         rm "${D}"/usr/sbin/setup || "Removing upstreams setup bin failed"
54
55         dodoc *.txt || die "dodoc failed"
56 }
57
58 pkg_postinst() {
59         einfo "Make sure to configure webcit under /etc/conf.d/webcit."
60         einfo "Then start the server with /etc/init.d/webcit start"
61         einfo
62         einfo "Webcit will listen on port 2000 by default"
63 }