]> Pileus Git - ~andy/sunrise/blob - www-misc/profile-sync-daemon/profile-sync-daemon-3.1.ebuild
www-misc/profile-sync-daemon: version bump, remove old
[~andy/sunrise] / www-misc / profile-sync-daemon / profile-sync-daemon-3.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6
7 inherit eutils
8
9 MY_PN="psd"
10 DESCRIPTION="Symlinks and syncs browser profile dirs to RAM thus reducing HDD/SDD calls and speeding-up browsers"
11 HOMEPAGE="https://wiki.archlinux.org/index.php/Profile-sync-daemon"
12 SRC_URI="http://repo-ck.com/source/${PN}/${P}.tar.xz"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 DEPEND="app-arch/xz-utils"
20 RDEPEND="app-shells/bash
21         net-misc/rsync"
22
23 src_prepare() {
24         # fix manpage/readme for proper gentoo instructions
25         epatch "${FILESDIR}"/${PV}-manreadme.patch
26         # fix script to work with our initscript
27         epatch "${FILESDIR}"/${PV}-pid.patch
28 }
29
30 src_install() {
31         # script
32         dobin ${PN}
33
34         # optional cronjob
35         insinto /usr/share/${PN}
36         doins "${FILESDIR}"/cronjob
37
38         # initscript
39         newinitd "${FILESDIR}"/daemon ${MY_PN}
40
41         # conf
42         newconfd ${MY_PN}.conf ${MY_PN}
43
44         # manpage, readme
45         newdoc README-for_other_distros README
46         dodoc CHANGELOG
47         newman ${MY_PN}.manpage ${PN}.1
48 }
49
50 pkg_postinst() {
51         elog "For adding a cronjob use the file"
52         elog "/usr/share/${PN}/cronjob"
53 }