]> Pileus Git - ~andy/sunrise/blob - www-misc/profile-sync-daemon/profile-sync-daemon-3.0-r1.ebuild
games-arcade/mari0: New Ebuild for bug 407105 thanks to Tommy[D] Enlik mrueg Zero_Cha...
[~andy/sunrise] / www-misc / profile-sync-daemon / profile-sync-daemon-3.0-r1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6
7 inherit eutils
8
9 MY_PN="psd"
10 DESCRIPTION="Symlinks and syncs browser profile dirs to RAM thus reducing HDD/SDD calls and speeding-up browsers"
11 HOMEPAGE="https://wiki.archlinux.org/index.php/Profile-sync-daemon"
12 SRC_URI="http://repo-ck.com/source/${PN}/${P}.tar.xz"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 DEPEND="app-arch/xz-utils"
20 RDEPEND="net-misc/rsync"
21
22 src_prepare() {
23         # fix manpage/readme for proper gentoo instructions
24         epatch "${FILESDIR}"/${MY_PN}-manreadme.patch
25         # fix script to work with our daemon
26         epatch "${FILESDIR}"/${MY_PN}-pid.patch
27 }
28
29 src_install() {
30         # install script
31         dobin ${PN}
32
33         # install conf
34         insinto /etc
35         doins ${MY_PN}.conf
36
37         # install optional cronjob
38         insinto /usr/share/${PN}
39         doins "${FILESDIR}"/cronjob
40
41         # install our daemon
42         newinitd "${FILESDIR}"/daemon ${MY_PN}
43
44         # manpage, readme
45         newdoc README* README
46         dodoc CHANGELOG
47         newman ${MY_PN}.manpage ${PN}.1
48 }
49
50 pkg_postinst() {
51         elog "For adding a cronjob use the file"
52         elog "/usr/share/${PN}/cronjob"
53 }