]> Pileus Git - ~andy/sunrise/blob - www-client/seamonkey-bin/seamonkey-bin-1.0.7.ebuild
dev-python/pysvn: Import for bug #62852
[~andy/sunrise] / www-client / seamonkey-bin / seamonkey-bin-1.0.7.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils mozilla-launcher multilib
6
7 DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
8 SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/${PV}/seamonkey-${PV}.en-US.linux-i686.tar.gz"
9 HOMEPAGE="http://www.mozilla.org/projects/seamonkey/"
10 RESTRICT="strip"
11
12 KEYWORDS="~amd64 ~x86"
13 SLOT="0"
14 LICENSE="MPL-1.1 NPL-1.1"
15 IUSE=""
16
17 DEPEND="app-arch/unzip
18         !www-client/mozilla"
19 RDEPEND="x11-libs/libXrender
20         x11-libs/libXt
21         x11-libs/libXmu
22         x86? (
23                 >=sys-libs/lib-compat-1.0-r2
24                 >=x11-libs/gtk+-2.2
25                 =virtual/libstdc++-3.3
26         )
27         amd64? (
28                 >=app-emulation/emul-linux-x86-baselibs-1.0
29                 >=app-emulation/emul-linux-x86-gtklibs-1.0
30                 app-emulation/emul-linux-x86-compat
31         )
32         >=www-client/mozilla-launcher-1.41
33         virtual/libc"
34
35 S=${WORKDIR}/seamonkey
36
37 pkg_setup() {
38         # This is a binary x86 package => ABI=x86
39         # Please keep this in future versions
40         # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
41         has_multilib_profile && ABI="x86"
42 }
43
44 src_install() {
45         declare MOZILLA_FIVE_HOME=/opt/seamonkey
46
47         # Install seamonkey in /opt
48         dodir ${MOZILLA_FIVE_HOME%/*}
49         mv "${S}" "${D}${MOZILLA_FIVE_HOME}"
50
51         # Create /usr/bin/seamonkey-bin
52         install_mozilla_launcher_stub seamonkey-bin ${MOZILLA_FIVE_HOME}
53
54         # Install icon and .desktop for menu entry
55         insinto /usr/share/pixmaps
56         doins "${FILESDIR}/icon/seamonkey-bin.png"
57         insinto /usr/share/applications
58         doins "${FILESDIR}/icon/seamonkey-bin.desktop"
59
60         # revdep-rebuild entry
61         insinto /etc/revdep-rebuild
62         doins "${FILESDIR}/10seamonkey-bin"
63 }
64
65 pkg_preinst() {
66         declare MOZILLA_FIVE_HOME=/opt/seamonkey
67
68         # Remove entire installed instance to prevent all kinds of
69         # problems... see bug 44772 for example
70         rm -rf "${ROOT}${MOZILLA_FIVE_HOME}"
71 }
72
73 pkg_postinst() {
74         if use amd64; then
75                 echo
76                 einfo "NB: You just installed a 32-bit seamonkey"
77         fi
78
79         update_mozilla_launcher_symlinks
80 }
81
82 pkg_postrm() {
83         update_mozilla_launcher_symlinks
84 }