]> Pileus Git - ~andy/sunrise/blob - www-client/seamonkey-bin/seamonkey-bin-1.0.5.ebuild
4008cfd167eea73c3323d788e0c06ab5a3831532
[~andy/sunrise] / www-client / seamonkey-bin / seamonkey-bin-1.0.5.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils mozilla-launcher multilib
6
7 DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
8 SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/${PV}/seamonkey-${PV}.en-US.linux-i686.tar.gz"
9 HOMEPAGE="http://www.mozilla.org/projects/seamonkey"
10 RESTRICT="nostrip"
11
12 KEYWORDS="-* ~amd64 ~x86"
13 SLOT="0"
14 LICENSE="MPL-1.1 NPL-1.1"
15 IUSE=""
16
17 DEPEND="app-arch/unzip
18         !www-client/mozilla"
19 RDEPEND="x11-libs/libXrender
20         x11-libs/libXt
21         x11-libs/libXmu
22         x86? (
23                 >=sys-libs/lib-compat-1.0-r2
24                 >=x11-libs/gtk+-2.2
25         )
26         amd64? (
27                 >=app-emulation/emul-linux-x86-baselibs-1.0
28                 >=app-emulation/emul-linux-x86-gtklibs-1.0
29         )
30         >=www-client/mozilla-launcher-1.41
31         =virtual/libstdc++-3.3
32         virtual/libc"
33
34 S=${WORKDIR}/seamonkey
35
36 pkg_setup() {
37         # This is a binary x86 package => ABI=x86
38         # Please keep this in future versions
39         # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
40         has_multilib_profile && ABI="x86"
41 }
42
43 src_install() {
44         declare MOZILLA_FIVE_HOME=/opt/seamonkey
45
46         # Install seamonkey in /opt
47         dodir ${MOZILLA_FIVE_HOME%/*}
48         mv "${S}" "${D}${MOZILLA_FIVE_HOME}"
49
50         # Create /usr/bin/seamonkey-bin
51         install_mozilla_launcher_stub seamonkey-bin ${MOZILLA_FIVE_HOME}
52
53         # Install icon and .desktop for menu entry
54         insinto /usr/share/pixmaps
55         doins "${FILESDIR}/icon/seamonkey-bin-icon.png"
56         insinto /usr/share/applications
57         doins "${FILESDIR}/icon/seamonkey-bin.desktop"
58
59         # revdep-rebuild entry
60         insinto /etc/revdep-rebuild
61         doins "${FILESDIR}/10seamonkey-bin"
62 }
63
64 pkg_preinst() {
65         declare MOZILLA_FIVE_HOME=/opt/seamonkey
66
67         # Remove entire installed instance to prevent all kinds of
68         # problems... see bug 44772 for example
69         rm -rf "${ROOT}${MOZILLA_FIVE_HOME}"
70 }
71
72 pkg_postinst() {
73         if use amd64; then
74                 echo
75                 einfo "NB: You just installed a 32-bit seamonkeyx"
76         fi
77
78         update_mozilla_launcher_symlinks
79 }
80
81 pkg_postrm() {
82         update_mozilla_launcher_symlinks
83 }