]> Pileus Git - ~andy/sunrise/blob - www-apps/wwwsqldesigner/wwwsqldesigner-2.6.ebuild
ad1797a7ce3ae96ade112286ecb3660c83790e81
[~andy/sunrise] / www-apps / wwwsqldesigner / wwwsqldesigner-2.6.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit webapp
8
9 DESCRIPTION="Visual web-based SQL modelling tool"
10 HOMEPAGE="http://code.google.com/p/wwwsqldesigner/"
11 SRC_URI="http://wwwsqldesigner.googlecode.com/files/${P}.zip"
12
13 LICENSE="BSD-2"
14 KEYWORDS="~x86"
15 IUSE=""
16
17 DEPEND="app-arch/unzip"
18
19 src_install() {
20         webapp_src_preinst
21
22         insinto "${MY_HTDOCSDIR}"
23         doins -r .
24
25         webapp_configfile "${MY_HTDOCSDIR}"/backend/php-{blank,cubrid,file,mysql,mysql+file,pdo,postgresql,sqlite}/index.php "${MY_HTDOCSDIR}"/backend/cf-mysql/index.cfm "${MY_HTDOCSDIR}"/backend/perl-file/index.pl "${MY_HTDOCSDIR}"/js/config.js
26
27         webapp_src_install
28 }
29
30 pkg_postinst() {
31         elog "To use server-side save/load functionality, you need to configure the"
32         elog "respective storage backend(s)."
33         elog "E.g. for php-mysql you need to import the table definition from"
34         elog "backend/php-mysql/database.sql and enter connection credentials into"
35         elog "backend/php-mysql/index.php"
36         elog
37         elog "For more information see http://code.google.com/p/wwwsqldesigner/w/list"
38 }