]> Pileus Git - ~andy/sunrise/blob - sys-process/daemon/daemon-0.6.3.ebuild
809c45acf8c5b525034bb6d83999562905cb8326
[~andy/sunrise] / sys-process / daemon / daemon-0.6.3.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit toolchain-funcs
6
7 DESCRIPTION="Daemon turns other process into daemons, respawning automatically"
8 HOMEPAGE="http://www.libslack.org/daemon/"
9 SRC_URI="http://libslack.org/daemon/download/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="-amd64 ~x86"
14 IUSE=""
15 RESTRICT="test"
16
17 DEPEND=""
18 RDEPEND=""
19
20 src_unpack() {
21         unpack ${A}
22         cd "${S}"
23         sed -i -e '/strip/d' rules.mk
24 }
25
26 src_compile() {
27         ./config
28         emake CC="$(tc-getCC)" AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" \
29                 CCFLAGS="${CFLAGS}" PREFIX="/usr" || die "emake failed"
30 }
31
32 src_install() {
33         emake PREFIX="${D}/usr" install || die "emake install failed"
34         dodoc README
35 }