]> Pileus Git - ~andy/sunrise/blob - sys-fs/tdu/tdu-2008.05.07.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / sys-fs / tdu / tdu-2008.05.07.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils versionator toolchain-funcs
8
9 MY_P="${PN}-$(replace_all_version_separators - ${PV})"
10
11 DESCRIPTION="terminal program that displays disk space utilization in an interactive full-screen folding outline"
12 HOMEPAGE="http://webonastick.com/tdu/"
13 SRC_URI="${HOMEPAGE}/${MY_P}.tar.gz"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 RDEPEND="
21         sys-libs/ncurses
22         dev-libs/glib:2"
23 DEPEND="${RDEPEND}
24         dev-util/pkgconfig"
25 S="${WORKDIR}"/${PN}
26
27 src_prepare() {
28         epatch \
29                 "${FILESDIR}"/${PV}-DESTDIR.patch \
30                 "${FILESDIR}"/${PV}-asneeded.patch
31         tc-export CC
32 }