]> Pileus Git - ~andy/sunrise/blob - sys-fs/ext3grep/ext3grep-0.10.1.ebuild
Removed unused eutils inherit, econf needs no die statement.
[~andy/sunrise] / sys-fs / ext3grep / ext3grep-0.10.1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit base
6
7 DESCRIPTION="recover deleted files on an ext3 file system"
8 HOMEPAGE="http://www.xs4all.nl/~carlo17/howto/undelete_ext3.html"
9 SRC_URI="http://ext3grep.googlecode.com/files/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15
16 IUSE="debug largefile libcwd pch"
17 RDEPEND=""
18 DEPEND="${RDEPEND}
19         debug? ( libcwd? ( dev-cpp/libcwd ) )"
20
21 PATCHES=( "${FILESDIR}"/gcc-4.3.patch )
22
23 src_compile() {
24         local myconf
25
26         use debug && myconf="--disable-optimize"
27
28         econf ${myconf} \
29                 $(use_enable libcwd) \
30                 $(use_enable debug) \
31                 $(use_enable pch) \
32                 $(use_enable largefile)
33
34         emake || die "emake failed"
35 }
36
37
38 src_install() {
39         emake DESTDIR="${D}" install || die
40
41         dodoc NEWS README || die
42 }