]> Pileus Git - ~andy/sunrise/blob - sys-fs/cryptmount/cryptmount-1.2.ebuild
0d3643734ee60f394cb2687b7ef77cdf1a016f19
[~andy/sunrise] / sys-fs / cryptmount / cryptmount-1.2.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit linux-info
6
7 DESCRIPTION="A utility for management and user-mode mounting of encrypted filesystems"
8 HOMEPAGE="http://cryptmount.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="nls ssl"
15
16 RDEPEND="sys-fs/device-mapper
17         >=dev-libs/libgcrypt-1.1.94
18         ssl? ( dev-libs/openssl )
19         nls? ( virtual/libintl )"
20 DEPEND="${RDEPEND}
21         nls? ( sys-devel/gettext )"
22
23 CONFIG_CHECK="BLK_DEV_DM"
24 ERROR_BLK_DEV_DM="Please enable Device mapper support in your kernel config
25         -> Device Drivers
26                 -> Multi-device support (RAID and LVM)
27                         -> Multiple devices driver support (RAID and LVM) (MD)
28                                 <M> Device mapper support"
29
30 src_compile() {
31         econf \
32                 --with-gnu-ld \
33                 --with-libgcrypt \
34                 $(use_enable nls) \
35                 $(use_with ssl openssl) \
36         || die "econf failed"
37
38         emake || die "emake failed"
39 }
40
41 src_install() {
42         emake install DESTDIR="${D}" || die "emake install failed"
43         dodoc AUTHORS ChangeLog NEWS README RELNOTES ToDo
44 }