]> Pileus Git - ~andy/sunrise/blob - sys-fs/cromfs/cromfs-1.5.8.9.ebuild
e1061aaa03a486d896e90e59ca3173c037b80286
[~andy/sunrise] / sys-fs / cromfs / cromfs-1.5.8.9.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="a FUSE based compressed read-only filesystem for Linux."
6 HOMEPAGE="http://bisqwit.iki.fi/source/cromfs.html"
7 SRC_URI="http://bisqwit.iki.fi/src/arch/${P}.tar.bz2"
8
9 LICENSE="GPL-3"
10 SLOT="0"
11 KEYWORDS="~x86 ~amd64"
12 IUSE="static"
13
14 DEPEND=">=sys-fs/fuse-2.5.2"
15 RDEPEND="${DEPEND}"
16
17 src_compile() {
18         sed -i -e '/upx/d' -e '/- strip/d' Makefile || \
19                 die "sed failed to remove UPX and strip."
20         econf
21         emake || die "Make failed."
22 }
23
24 src_install() {
25         if use static; then
26                 dobin cromfs-driver-static || \
27                         die "Couldn't find the static binary to install."
28         fi
29         dobin cromfs-driver util/mkcromfs util/unmkcromfs util/cvcromfs || \
30                 die "Some binaries failed to install."
31         dodoc doc/*.txt doc/FORMAT doc/ChangeLog || die "dodoc failed"
32         dohtml doc/*.html doc/*.png || die "dohtml failed"
33 }