]> Pileus Git - ~andy/sunrise/blob - sys-devel/boost-m4/boost-m4-0.2.ebuild
sys-devel/boost-m4: Bump to boost-m4-0.2, thanks to Erik Zeek per bug 352618 comment 4.
[~andy/sunrise] / sys-devel / boost-m4 / boost-m4-0.2.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 DESCRIPTION="Another set of autoconf macros for compiling against boost"
8 HOMEPAGE="http://github.com/tsuna/boost.m4"
9 SRC_URI="${HOMEPAGE}/zipball/v${PV} -> ${P}.zip"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64"
14 IUSE=""
15
16 DEPEND="app-arch/unzip"
17 RDEPEND=""
18
19 src_unpack() {
20         default
21
22         mv * ${P} || die
23 }
24
25 # boost.m4 has a buildsystem, but the distributer didn't use make dist
26 # so we'd have to eautoreconf to use it. For installing one file, this
27 # isn't worth it.
28 src_configure() { :; }
29
30 src_compile() { :; }
31
32 src_install() {
33         insinto /usr/share/aclocal
34         doins build-aux/boost.m4 || die
35
36         dodoc AUTHORS NEWS README THANKS || die
37 }