]> Pileus Git - ~andy/sunrise/blob - sys-auth/pam_pgsql/pam_pgsql-1.0.0.ebuild
sunrise/app-portage/overlay-utils/overlay-utils-0.2.ebuild: Update copyright headers...
[~andy/sunrise] / sys-auth / pam_pgsql / pam_pgsql-1.0.0.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 WANT_AUTOCONF="2.1"
6 inherit pam autotools
7
8 DESCRIPTION="pam_pgsql is a module for pam to authenticate users with PostgreSQL"
9 HOMEPAGE="http://pgfoundry.org/frs/?group_id=1000039"
10 SRC_URI="mirror://postgresql/projects/pgFoundry/sysauth/${PN/_/-}-${PV}.tgz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 IUSE=""
15 KEYWORDS="~amd64 ~x86"
16
17 DEPEND=">=sys-libs/pam-0.78-r3
18         >=app-crypt/mhash-0.9.1
19         >=dev-db/postgresql-7.3.6"
20 RDEPEND="${DEPEND}"
21
22 S="${WORKDIR}/${PN/_/-}"
23
24 src_install() {
25         insinto /etc
26         newins "${FILESDIR}/pam_pgsql.conf" pam_pgsql.conf
27         dopammod pam_pgsql.so
28         dodoc debian/changelog README CREDITS
29 }
30
31 pkg_postinst() {
32         elog "From version 0.6 you can also use new style configuration (overrides"
33         elog "legacy values). See /usr/share/doc/${PF}/README for more info."
34 }