]> Pileus Git - ~andy/sunrise/blob - sys-auth/pam_mount/pam_mount-0.18.ebuild
Cosmetics
[~andy/sunrise] / sys-auth / pam_mount / pam_mount-0.18.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 WANT_AUTOCONF="latest"
6 WANT_AUTOMAKE="latest"
7 inherit eutils pam autotools
8
9 DESCRIPTION="A PAM module that can mount volumes for a user session e.g. encrypted home directories"
10 HOMEPAGE="http://pam-mount.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="crypt"
17
18 DEPEND=">=sys-libs/pam-0.78-r3
19         >=dev-libs/openssl-0.9.7i
20         >=dev-libs/glib-2"
21 RDEPEND="${DEPEND}
22         crypt? ( sys-fs/cryptsetup-luks )
23         sys-process/lsof"
24
25 src_unpack() {
26         unpack ${A}
27         cd "${S}"
28
29         # Gentoo installs cryptsetup in /bin, this patches the relevant
30         # locations, in scripts/(u)mount.crypt and adds gentoo specific
31         # comments to pam_mount.conf
32         epatch "${FILESDIR}/${PN}-gentoo-paths-and-examples.patch"
33
34         eautoreconf
35 }
36
37 src_compile() {
38         econf \
39                 --with-slibdir=/$(get_libdir) || die "econf failed"
40         emake || die "emake failed"
41 }
42
43 src_install() {
44         emake DESTDIR="${D}" install || die "install failed"
45
46         insinto /etc/security
47         insopts -m0644
48         doins "${S}/config/pam_mount.conf"
49         dopamd "${FILESDIR}/system-auth"
50
51         dodoc README TODO AUTHORS ChangeLog FAQ NEWS
52 }
53
54 pkg_postinst() {
55         elog "In order to use pam_mount you will need to configure it."
56         elog "After the modifications in /etc/security/pam_mount.conf you "
57         elog "can create the encrypted directory using the mkehd command."
58         elog "Please use mkhed -h for more informations."
59         elog
60         elog "If you want to encrypt the home directories you will need a "
61         elog "kernel with device-mapper and crypto (AES or any other chipher)"
62         elog "support."
63         elog
64         elog "This ebuild only modifies the /etc/pam.d/system-auth file to"
65         elog "support pam_mount. If you have any programs that use pam with "
66         elog "a configuration file that does NOT include system-auth you will "
67         elog "need to modify this file too. Look at /etc/pam.d/system-auth or "
68         elog "the /usr/share/doc/${PF}/README file for more informations."
69 }