]> Pileus Git - ~andy/sunrise/blob - sys-apps/uam/uam-0.0.5.ebuild
db6feb5d2f611747c5c6762be4c446a05d3e75de
[~andy/sunrise] / sys-apps / uam / uam-0.0.5.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils multilib
6
7 DESCRIPTION="Simple udev-based automounter for removable USB media"
8 HOMEPAGE="http://github.com/mgorny/uam/"
9 SRC_URI="http://github.com/downloads/mgorny/${PN}/${P}.tar.bz2"
10
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~amd64"
14 IUSE=""
15
16 DEPEND=""
17 RDEPEND="sys-fs/udev"
18
19 src_compile() {
20         emake LIBDIR=/$(get_libdir) || die
21 }
22
23 src_install() {
24         emake LIBDIR=/$(get_libdir) DESTDIR="${D}" install || die
25
26         dodoc NEWS README TODO || die
27 }
28
29 pkg_postinst() {
30         # such group is created by pam, pmount any many other ebuilds
31         # but we don't want to depend on any of them (even pmount is optional)
32         enewgroup plugdev
33
34         elog "To be able to access uam-mounted filesystems, you have to be member"
35         elog "of the 'plugdev' group."
36         elog
37         elog "Note that uam doesn't provide any way to allow unprivileged user to"
38         elog "manually umount devices. You may use pumount from sys-apps/pmount"
39         elog "for that. Otherwise, remember to sync before removing your USB stick."
40         elog
41         elog "Another feature uam is not capable of is mounting removable media"
42         elog "in fixed drives, like CDs and floppies. You might, however, be able"
43         elog "to mount them as an unprivileged user using appropriate fstab entries"
44         elog "or sys-apps/pmount."
45         elog
46         elog "If you'd like to receive libnotify-based notifications, you need"
47         elog "to install the [x11-misc/sw-notify-send] tool."
48
49         ebegin "Calling udev to reload its rules"
50         udevadm control --reload-rules
51         eend $?
52 }