]> Pileus Git - ~andy/sunrise/blob - sys-apps/fwts/fwts-0.26.01.ebuild
d8dd8f2e99fcc79ceb058c3989d792adc0b3234b
[~andy/sunrise] / sys-apps / fwts / fwts-0.26.01.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit autotools
8 DESCRIPTION="Firmware Test Suite"
9 HOMEPAGE="https://wiki.ubuntu.com/Kernel/Reference/fwts"
10 SRC_URI="http://launchpad.net/ubuntu/+archive/primary/+files/${PN}_${PV}.orig.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64"
15 IUSE=""
16
17 RDEPEND="dev-libs/json-c
18         dev-libs/libpcre
19         sys-apps/pciutils
20         sys-power/iasl
21         sys-power/pmtools
22         sys-apps/dmidecode"
23 DEPEND="${RDEPEND}
24         sys-devel/libtool"
25
26 S=${WORKDIR}
27
28 src_prepare(){
29         sed -i -e 's/-Wall -Werror/-Wall/' configure.ac {,src/,src/lib/src/}Makefile.am || die
30         sed -i -e 's:/usr/bin/lspci:/usr/sbin/lspci:' src/lib/include/fwts_binpaths.h || die
31         # No Makefile included - upstream wants autoreconf
32         eautoreconf
33 }