]> Pileus Git - ~andy/sunrise/blob - sci-visualization/tulip/tulip-3.1.2.ebuild
sci-visualization/tulip: Properly fix qt deps
[~andy/sunrise] / sci-visualization / tulip / tulip-3.1.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6
7 inherit autotools multilib user
8
9 DESCRIPTION="Large Graph Visualization System"
10 HOMEPAGE="http://tulip.labri.fr/"
11 SRC_URI="mirror://sourceforge/auber/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16
17 IUSE="stats tlprender"
18
19 RDEPEND="dev-libs/libxml2
20         media-libs/freetype:2
21         media-libs/glew
22         dev-qt/qthelp:4
23         dev-qt/qtgui:4
24         dev-qt/qtopengl:4"
25 DEPEND="${RDEPEND}"
26
27 pkg_setup() {
28         enewgroup tulip
29 }
30
31 src_unpack() {
32         unpack ${A}
33         cd "${S}"
34         eautoreconf
35 }
36
37 src_compile() {
38         econf   $(use_enable tlprender) \
39                 $(use_enable stats stat-gui) \
40                 "--with-qt-includes=/usr/include/qt4" \
41                 "--with-qt-libraries=/usr/$(get_libdir)/qt4" \
42                 "MOC=/usr/bin/moc"
43         emake || die "make failed"
44 }
45
46 src_install() {
47         emake DESTDIR="${D}" install || die "Install failed"
48         rm -r "${D}/usr/share/tulip"
49         dodoc TODO README AUTHORS ChangeLog || die "dodoc failed"
50 }