]> Pileus Git - ~andy/sunrise/blob - sci-visualization/spyview/spyview-20100109.ebuild
c6785b4500d7c479b9b51014aa5b9e70009b6fc2
[~andy/sunrise] / sci-visualization / spyview / spyview-20100109.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header $
4
5 EAPI=2
6
7 inherit base flag-o-matic eutils multilib
8
9 DESCRIPTION="Interactive plotting program"
10 HOMEPAGE="http://kavli.nano.tudelft.nl/~gsteele/spyview/"
11 SRC_URI="http://kavli.nano.tudelft.nl/~gsteele/${PN}/versions/${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 COMMON_DEPEND=">=dev-libs/boost-1.35
19         media-libs/netpbm
20         >=x11-libs/fltk-1.1.9:1.1
21         app-text/ghostscript-gpl"
22
23 DEPEND="${COMMON_DEPEND}
24         sys-apps/groff"
25
26 RDEPEND="${COMMON_DEPEND}
27         sci-visualization/gnuplot"
28
29 S=${WORKDIR}/spyview-2010-01-09-17_39
30
31 src_prepare() {
32         epatch "${FILESDIR}"/${P}-includes.patch
33
34         append-cflags $(fltk-config --cflags)
35         append-cxxflags $(fltk-config --cxxflags) -I/usr/include/netpbm
36
37         # append-ldflags $(fltk-config --ldflags)
38         # this one leads to an insane amount of warnings
39
40         append-ldflags -L/usr/$(get_libdir)/fltk-1.1
41 }
42
43 src_configure() {
44         econf --datadir=/usr/share/spyview
45 }