]> Pileus Git - ~andy/sunrise/blob - sci-physics/KRT/KRT-2009.11.20.09.34.38.ebuild
c716a143503032b11540a98905a447deeae821bd
[~andy/sunrise] / sci-physics / KRT / KRT-2009.11.20.09.34.38.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=1
6
7 inherit cmake-utils eutils versionator
8
9 MY_P=${PN}-$(replace_version_separator 3 -)
10 DESCRIPTION="A lattice solver"
11 HOMEPAGE="http://czlug.icis.pcz.pl/~zygmunt/programs/KRT/"
12 SRC_URI="http://czlug.icis.pcz.pl/~zygmunt/public/programs/${MY_P}.tar.bz2"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE="examples"
18
19 DEPEND="x11-libs/qt-gui:4
20         x11-libs/qt-opengl:4"
21 RDEPEND="${DEPEND}"
22
23 S=${WORKDIR}/${PN}
24
25 src_install() {
26         _check_build_dir
27         dobin "${CMAKE_BUILD_DIR}"/${PN} || die
28
29         if use examples; then
30                 docinto examples
31                 dodoc example/* || die
32         fi
33
34         doicon "${FILESDIR}"/${PN}.xpm || die
35         make_desktop_entry ${PN} ${PN} ${PN} 'Education;Science;Engineering'
36 }