]> Pileus Git - ~andy/sunrise/blob - sci-misc/ised/ised-2.2.1.ebuild
app-misc/bashstyle-ng: Patch file renamed and KEYWORDS sorted
[~andy/sunrise] / sci-misc / ised / ised-2.2.1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 DESCRIPTION="A tool for generating sequences and arithmetic evaluation of stream data"
8 HOMEPAGE="http://ised.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~x86 ~amd64"
14 IUSE="long-types"
15
16 DEPEND="sys-libs/readline"
17 RDEPEND="${DEPEND}"
18
19 src_configure() {
20         use long-types && local type_conf="INT_TYPE=LONG FLOAT_TYPE=LONG"
21         econf --with-readline ${type_conf}
22 }
23
24 src_install() {
25         emake install DESTDIR="${D}" || die 'install failed'
26         dodoc AUTHORS ChangeLog NEWS README || die 'dodoc failed'
27 }