]> Pileus Git - ~andy/sunrise/blob - sci-mathematics/alberta/alberta-1.2.1.ebuild
2ea3a36b8a3c213fde33b69595aca2f89aac8694
[~andy/sunrise] / sci-mathematics / alberta / alberta-1.2.1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="An adaptive hierarchical finite element toolbox"
8 HOMEPAGE="http://www.alberta-fem.de/"
9 SRC_URI="http://www.alberta-fem.de/Downloads/${P/.1}.tar.gz
10         http://gentooexperimental.org/~genstef/dist/${P}.patch.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DEPEND="virtual/blas
18         virtual/opengl"
19 RDEPEND="${DEPEND}"
20
21 S="${WORKDIR}/${P/.1}"
22
23 src_unpack() {
24         unpack ${A}
25         cd "${S}"
26
27         # A working version of the 1.2.1 patch provided by upstream
28         epatch "${WORKDIR}/${P}.patch"
29 }
30
31 src_compile() {
32         # There exists no ebuild for gltools nor grape, disabling it
33         econf \
34                 --without-gltools \
35                 --without-grape
36         emake || die "emake failed"
37 }
38
39 src_install() {
40         emake DESTDIR="${D}" install || die "emake install failed"
41         dodoc README THANKS AUTHORS NEWS || die "dodoc failed"
42 }