]> Pileus Git - ~andy/sunrise/blob - sci-libs/rsl/rsl-1.43.ebuild
sci-geosciences/aweather: Version bump for aweather-0.8.1
[~andy/sunrise] / sci-libs / rsl / rsl-1.43.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils autotools
8
9 MY_P="${PN}-v${PV}"
10
11 DESCRIPTION="Radar Software Library"
12 HOMEPAGE="http://trmm-fc.gsfc.nasa.gov/trmm_gv/software/rsl/index.html"
13 SRC_URI="ftp://trmm-fc.gsfc.nasa.gov/software/${MY_P}.tar.gz"
14
15 LICENSE="LGPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="hdf"
19
20 RDEPEND="hdf? ( sci-libs/hdf )"
21 DEPEND="${RDEPEND}"
22
23 S="${WORKDIR}/${MY_P}"
24
25 src_prepare() {
26         epatch "${FILESDIR}/${PN}-"{automake,with_hdf}".patch"
27         eautoreconf
28 }
29
30 src_configure() {
31         econf $(use_with hdf)
32 }