]> Pileus Git - ~andy/sunrise/blob - sci-libs/nurbs++/nurbs++-3.0.11.ebuild
c3631c3b91d795ce228ac2f829a45f811bd50987
[~andy/sunrise] / sci-libs / nurbs++ / nurbs++-3.0.11.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit libtool eutils
6
7 DESCRIPTION="Non-Uniform Rational B-Splines (NURBS) curves and surface are parametric functions which can represent any type of curves or surfaces. This C++ library provides the basic methods for NURBS."
8 HOMEPAGE="http://libnurbs.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/libnurbs/${P}.tar.bz2"
10
11 LICENSE="LGPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="debug"
15
16 DEPEND="dev-lang/perl"
17 RDEPEND=""
18
19 src_unpack() {
20         unpack ${A}
21         cd "${S}"
22         epatch "${FILESDIR}"/nurbs++-3.0.11-gcc-4.1.patch
23         elibtoolize
24 }
25
26 src_compile() {
27         econf \
28                 --without-x \
29                 $(use_enable debug) \
30                 $(use_enable debug verbose-exception) \
31                 || die "econf failed!"
32         emake || die "emake failed!"
33 }
34
35 src_install() {
36         emake DESTDIR="${D}" install || die "emake install failed!"
37         dodoc AUTHORS ChangeLog NEWS README
38 }