]> Pileus Git - ~andy/sunrise/blob - sci-geosciences/aweather/aweather-9999.ebuild
sci-geosciences/aweather: Migrating from Subversion to Git
[~andy/sunrise] / sci-geosciences / aweather / aweather-9999.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EGIT_REPO_URI="git://lug.rose-hulman.edu/proj/aweather"
6 EGIT_BOOTSTRAP="gtkdocize && eautoreconf"
7
8 inherit autotools gnome2 git
9
10 DESCRIPTION="A weather monitoring program"
11 HOMEPAGE="http://lug.rose-hulman.edu/wiki/AWeather"
12 SRC_URI=""
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS=""
17 IUSE="doc"
18
19 RDEPEND=">=net-libs/libsoup-2.26
20         >=x11-libs/gtk+-2.16
21         x11-libs/gtkglext
22         sci-libs/rsl"
23
24 # gtk-doc-am needed to eautoreconf
25 DEPEND="${RDEPEND}
26         dev-util/gtk-doc-am
27         doc? ( dev-util/gtk-doc )"
28
29 DOCS="ChangeLog README TODO"
30
31 # Fix for gtk-doc bug
32 MAKEOPTS="${MAKEOPTS} -j1"