]> Pileus Git - ~andy/sunrise/blob - sci-geosciences/aweather/aweather-9999.ebuild
sci-geosciences/aweather: Bump to 0.8, update homepage, and test on amd64
[~andy/sunrise] / sci-geosciences / aweather / aweather-9999.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6 EGIT_REPO_URI="git://pileus.org/aweather"
7 EGIT_BOOTSTRAP="eautoreconf"
8
9 inherit autotools gnome2 git-2
10
11 DESCRIPTION="A weather monitoring program"
12 HOMEPAGE="http://pileus.org/aweather"
13 SRC_URI=""
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS=""
18 IUSE="gps"
19
20 RDEPEND="~sci-libs/grits-9999
21         x11-libs/gtk+:2
22         sci-libs/rsl
23         gps? ( >=sci-geosciences/gpsd-3 )"
24 DEPEND="${RDEPEND}"
25
26 DOCS="ChangeLog README TODO"
27
28 pkg_setup() {
29         G2CONF="${G2CONF}
30                 $(use_enable gps)"
31 }