]> Pileus Git - ~andy/sunrise/blob - sci-biology/amos/amos-2.0.2.ebuild
aa0b3ae5444cc18a574785c95236a4202f7e99f4
[~andy/sunrise] / sci-biology / amos / amos-2.0.2.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit qt3
6
7 DESCRIPTION="A Modular, Open-Source whole genome assembler"
8 HOMEPAGE="http://amos.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 IUSE=""
14 KEYWORDS="~x86"
15
16 DEPEND="$(qt_min_version 3.3)"
17 RDEPEND="${DEPEND}
18         sci-biology/mummer"
19
20 src_compile() {
21         econf
22         # TODO: fix parallel make. Notified upstream
23         emake -j1 || die "emake failed"
24 }
25
26 src_install() {
27         emake DESTDIR="${D}" install
28 }