]> Pileus Git - ~andy/sunrise/blob - net-wireless/eeprom_93cx6/eeprom_93cx6-20070529.ebuild
net-wireless/eeprom_93cx6: Bump to newer snapshot
[~andy/sunrise] / net-wireless / eeprom_93cx6 / eeprom_93cx6-20070529.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit linux-mod
6
7 MY_PN="rt2x00-git"
8 DESCRIPTION="EEPROM reader routines for 93cx6 chipsets."
9 HOMEPAGE="http://rt2x00.serialmonkey.com/"
10 SRC_URI="http://dev.gentooexperimental.org/~jakub/distfiles/${MY_PN}-${PV}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~x86"
15 IUSE=""
16
17 DEPEND=""
18 RDEPEND=""
19
20 S="${WORKDIR}/drivers/misc"
21
22 BUILD_PARAMS="CONFIG_EEPROM_93CX6=m -C ${KV_DIR} M=${S}"
23 BUILD_TARGETS="modules"
24 MODULE_NAMES="eeprom_93cx6()"
25
26 src_unpack() {
27         unpack ${A}
28         echo "CFLAGS += -I${WORKDIR}/include" >> ${S}/Makefile
29 }
30
31 src_install() {
32         linux-mod_src_install
33         dodir /usr/include/eeprom_93cx6/linux/
34         insinto /usr/include/eeprom_93cx6/linux/
35         doins "${WORKDIR}"/include/linux/eeprom_93cx6.h
36 }