]> Pileus Git - ~andy/sunrise/blob - net-wireless/cowpatty/cowpatty-4.3.ebuild
net-wireless/cowpatty: net-wireless/cowpaty Initial checkin
[~andy/sunrise] / net-wireless / cowpatty / cowpatty-4.3.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils toolchain-funcs
8
9 DESCRIPTION="Audit the security of pre-shared keys selected in WiFi Protected Access (WPA) networks"
10 HOMEPAGE="http://www.willhackforsushi.com/Cowpatty.html"
11 SRC_URI="http://www.willhackforsushi.com/code/${PN}/${PV}/${P}.tgz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND="dev-libs/openssl
19         net-libs/libpcap"
20 DEPEND="${RDEPEND}"
21
22 src_prepare() {
23         epatch "${FILESDIR}"/${PV}-Makefile.patch
24 }
25
26 src_compile() {
27         emake CC=$(tc-getCC) || \
28                 die "emake failed"
29 }
30
31 src_install() {
32         emake DESTDIR="${D}" install || die "installation failed"
33         dodoc README AUTHORS CHANGELOG TODO FAQ || die "nothing to read"
34         insinto /usr/share/${PN}
35         doins *.dump dict || die "no acessory files"
36 }