]> Pileus Git - ~andy/sunrise/blob - net-print/splix/splix-0.0.2.ebuild
net-print/splix - and whitespaces
[~andy/sunrise] / net-print / splix / splix-0.0.2.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils toolchain-funcs
6
7 DESCRIPTION="A set of CUPS printer drivers for SPL (Samsung Printer Language) printers"
8 HOMEPAGE="http://splix.sourceforge.net/"
9 SRC_URI="http://heanet.dl.sourceforge.net/sourceforge/splix/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 DEPEND="~net-print/cupsddk-1.1.0_p20061207"
17 RDEPEND="${DEPEND}"
18
19 src_unpack() {
20         unpack ${A}
21         cd "${S}"
22         epatch "${FILESDIR}"/fixMakefile.patch
23 }
24
25 src_compile() {
26         emake CXX="$(tc-getCXX)" || die "emake failed"
27 }
28
29 src_install() {
30         CUPSFILTERDIR="$(cups-config --serverbin)/filter"
31         CUPSPPDDIR="$(cups-config --datadir)/model"
32
33         dodir "${CUPSFILTERDIR}"
34         dodir "${CUPSPPDDIR}"
35         emake DESTDIR="${D}" install || die "emake install failed"
36 }