]> Pileus Git - ~andy/sunrise/blob - net-p2p/tribler/tribler-4.1.7.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / net-p2p / tribler / tribler-4.1.7.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit python eutils
6
7 MY_PN="${PN/tribler/Tribler}"
8 MY_P="${MY_PN}_${PV}_src"
9 S="${WORKDIR}/${MY_P}"
10
11 DESCRIPTION="Python based Bittorrent/Internet TV application"
12 HOMEPAGE="http://www.tribler.org/"
13 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 RDEPEND=">=dev-lang/python-2.4
21         >=dev-libs/openssl-0.9.8
22         >=dev-python/wxpython-2.8
23         >=dev-python/m2crypto-0.16
24         >=media-video/vlc-0.9"
25 DEPEND="${RDEPEND}
26         app-arch/unzip
27         >=dev-lang/swig-1.3.25"
28
29 src_unpack() {
30         unpack ${A}
31         cd "${S}"
32
33         # Because tribler.py has Windows CR/LF at the end of its lines
34         edos2unix ${PN}.py
35 }
36
37 src_install() {
38         dodir /usr/share/${PN}
39         newbin tribler.sh tribler || die "Error: newbin failed"
40         insinto /usr/share/${PN}
41         doins -r ABC BitTornado Tribler Utility Dialogs icons Lang test \
42         TorrentMaker || die "Error: doins failed"
43         doins abcengine.py btdownloadheadless.py btshowmetainfo.py webtest.py \
44                 interconn.py launchmanycore.py webservice.py safeguiupdate.py \
45                 tribler.py *.ico *.xpm *.conf *.nsi *.command *.bmp cities.txt \
46                 people.txt superpeer.txt || die "Error: doins failed"
47         doicon ${PN}.xpm
48         make_desktop_entry "tribler" "Tribler P2P Bittorrent/Youtube client" \
49                 ${PN}.xpm "Application;Network;P2P"
50         insopts -m0700
51         doins btcreatetorrent.py btlaunchmany.py bttrack.py || die "Error: doins failed"
52         dodoc LICENSE.txt protocol_v3.txt readme.txt
53         cd "${S}/debian"
54         doman *.1
55 }
56
57 pkg_postinst() {
58         python_mod_optimize "${ROOT}"usr/share/${PN}
59         ewarn
60         ewarn "VLC has not Python bindings available yet"
61         ewarn "the internal player controls will not work."
62         ewarn
63 }
64
65 pkg_postrm() {
66         python_mod_cleanup "${ROOT}"usr/share/${PN}
67 }