]> Pileus Git - ~andy/sunrise/blob - net-misc/wolman/wolman-9999.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / net-misc / wolman / wolman-9999.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6 inherit qt4 subversion eutils
7
8 QT4_BUILT_WITH_USE_CHECK="png"
9
10 ESVN_REPO_URI="svn://svn.dolezel.info/${PN}/trunk/${PN}"
11 DESCRIPTION="GUI Wake-on-LAN manager"
12 HOMEPAGE="http://www.dolezel.info/projects/wolman"
13 SRC_URI=""
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS=""
18 IUSE=""
19
20 DEPEND="x11-libs/qt-gui:4
21         net-libs/libnet
22         net-libs/libpcap"
23 RDEPEND="${DEPEND}
24         sys-apps/iproute2"
25
26 S="${WORKDIR}/${PN}"
27
28 src_compile() {
29         eqmake4
30         emake || die "make failed"
31 }
32
33 src_install() {
34         dosbin wolman || die "dosbin failed"
35         newicon gfx/green.png ${PN}.png
36         make_desktop_entry ${PN} "Wake-on-LAN manager" ${PN} "Network;RemoteAccess;Qt" /usr/sbin
37 }