]> Pileus Git - ~andy/sunrise/blob - net-misc/wolman/wolman-9999.ebuild
net-misc/wolman: Properly fix qt deps
[~andy/sunrise] / net-misc / wolman / wolman-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 inherit qt4-r2 subversion eutils
7
8 QT4_BUILT_WITH_USE_CHECK="png"
9
10 ESVN_REPO_URI="svn://svn.dolezel.info/${PN}/trunk/${PN}"
11 DESCRIPTION="GUI Wake-on-LAN manager"
12 HOMEPAGE="http://www.dolezel.info/projects/wolman"
13 SRC_URI=""
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS=""
18 IUSE=""
19
20 DEPEND="dev-qt/qtgui:4
21         net-libs/libnet
22         net-libs/libpcap"
23 RDEPEND="${DEPEND}
24         sys-apps/iproute2"
25
26 S="${WORKDIR}/${PN}"
27
28 src_install() {
29         dosbin wolman || die "dosbin failed"
30         newicon gfx/green.png ${PN}.png
31         make_desktop_entry ${PN} "Wake-on-LAN manager" ${PN} "Network;RemoteAccess;Qt" /usr/sbin
32 }