]> Pileus Git - ~andy/sunrise/blob - net-misc/sshmenu/sshmenu-3.15.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / net-misc / sshmenu / sshmenu-3.15.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6 ## We need virtualx for src_test's Xmake stuff.
7 inherit eutils multilib virtualx
8
9 DESCRIPTION="A gnome applet interface to SSH."
10 HOMEPAGE="http://sshmenu.sourceforge.net"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE="gnome"
17
18 RDEPEND="dev-lang/ruby:1.8
19         dev-ruby/ruby-gtk2
20         gnome? ( dev-ruby/ruby-gconf2
21                 dev-ruby/ruby-panel-applet2 )
22         || ( net-misc/x11-ssh-askpass net-misc/gtk2-ssh-askpass )"
23
24 src_unpack() {
25         unpack ${A}
26         cd "${S}"
27         epatch "${FILESDIR}"/${P}-fixmultilib.patch
28 }
29
30 src_test() {
31         Xmake TEST || die "Tests failed!"
32 }
33
34 src_install() {
35         emake LIBDIR="$(get_libdir)" DESTDIR="${D}" install || die "Install failed!"
36
37         if ! use gnome; then
38                 rm "${D}"/usr/$(get_libdir)/ruby/1.8/gnome-sshmenu.rb
39                 rm "${D}"/usr/bin/sshmenu-gnome
40                 rm -rf "${D}"/usr/share/icons
41         fi
42 }