]> Pileus Git - ~andy/sunrise/blob - net-misc/miniupnpc/miniupnpc-1.4.ebuild
net-misc/autoupnp: Version bump.
[~andy/sunrise] / net-misc / miniupnpc / miniupnpc-1.4.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6 SUPPORT_PYTHON_ABIS=1
7 PYTHON_DEPEND="python? 2"
8 RESTRICT_PYTHON_ABIS="3.*"
9
10 inherit distutils eutils python toolchain-funcs
11
12 DESCRIPTION="UPnP client library and a simple UPnP client"
13 SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
14 HOMEPAGE="http://miniupnp.free.fr/"
15
16 LICENSE="BSD"
17 KEYWORDS="~amd64 ~x86"
18 SLOT="0"
19 IUSE="python"
20
21 src_prepare() {
22         epatch "${FILESDIR}"/${P}-cflags.diff
23         use python && distutils_src_prepare
24 }
25
26 src_compile() {
27         tc-export CC
28         emake || die
29         use python && distutils_src_compile
30 }
31
32 src_install() {
33         emake PREFIX="${D}" install || die "install failed"
34         dodoc README Changelog.txt || die "install failed"
35         doman man3/* || die "install failed"
36         use python && distutils_src_install
37 }