]> Pileus Git - ~andy/sunrise/blob - net-misc/freego/freego-4.ebuild
net-misc/freego: Fix qt deps
[~andy/sunrise] / net-misc / freego / freego-4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit qt4-r2
8
9 MY_P="FreeGo${PV}"
10
11 DESCRIPTION="Tool for users of Free, a French ISP, to manage their accounts"
12 HOMEPAGE="http://www.free-go.net/"
13 SRC_URI="http://www.freego.fr/logiciel/linux/sources/${MY_P}-src.zip"
14
15 LICENSE="GPL-1"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="doc"
19
20 RDEPEND="dev-libs/qtgui:4"
21 DEPEND="${RDEPEND}
22         app-arch/unzip"
23
24 S=${WORKDIR}/${MY_P}
25
26 src_prepare() {
27         sed -i -e '/PREFIX\t=.*/d' ${MY_P}.pro || die
28 }
29
30 src_configure() {
31         eqmake4 PREFIX=/usr
32 }
33
34 src_install() {
35         qt4-r2_src_install
36
37         dobin FreeGo || die
38         if use doc; then
39                 dodoc *.pdf || die
40         fi
41 }