]> Pileus Git - ~andy/sunrise/blob - net-misc/flexget/flexget-9999.ebuild
91cf39e1bef51f8b85af9143acf3c909d1d9c142
[~andy/sunrise] / net-misc / flexget / flexget-9999.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 PYTHON_DEPEND="2"
8 SUPPORT_PYTHON_ABIS="1"
9 DISTUTILS_SRC_TEST="setup.py"
10
11 inherit distutils subversion
12
13 DESCRIPTION="A multipurpose automation tool for content like torrents, nzbs, podcasts, comics, etc."
14 HOMEPAGE="http://flexget.com/"
15 ESVN_REPO_URI="http://svn.flexget.com/trunk"
16
17 LICENSE="MIT"
18 SLOT="0"
19 KEYWORDS=""
20 IUSE=""
21
22 RDEPEND="dev-python/setuptools
23         dev-python/feedparser
24         >=dev-python/sqlalchemy-0.6
25         dev-python/pyyaml
26         dev-python/beautifulsoup
27         >=dev-python/html5lib-0.11
28         dev-python/PyRSS2Gen
29         dev-python/pynzb
30         dev-python/progressbar
31         dev-python/flask
32         dev-python/cherrypy"
33 DEPEND="${RDEPEND}
34         dev-python/paver
35         test? ( >=dev-python/nose-0.11 )"
36
37 RESTRICT_PYTHON_ABIS="3.*"
38
39 src_prepare() {
40         # Prevent setup from grabbing nose from pypi
41         sed -e /setup_requires/d -i pavement.py || die
42
43         # Generate setup.py
44         paver generate_setup || die
45
46         distutils_src_prepare
47 }
48
49 pkg_postinst() {
50         distutils_pkg_postinst
51
52         ewarn "FlexGet's database schema may need to be updated manually."
53         ewarn "See http://flexget.com/wiki/UpgradeActions for more information."
54 }