]> Pileus Git - ~andy/sunrise/blob - net-misc/fatrat/fatrat-1.1.3.ebuild
net-misc/fatrat: Properly fix qt deps
[~andy/sunrise] / net-misc / fatrat / fatrat-1.1.3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit cmake-utils
8
9 DESCRIPTION="Qt4-based download/upload manager"
10 HOMEPAGE="http://fatrat.dolezel.info/"
11 SRC_URI="http://www.dolezel.info/download/data/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="bittorrent +curl doc jabber nls webinterface"
17
18 RDEPEND="dev-qt/qtgui:4[dbus]
19         dev-qt/qtsvg:4
20         bittorrent? ( >=net-libs/rb_libtorrent-0.14.5
21                         >=dev-cpp/asio-1.1.0
22                         dev-qt/qtwebkit:4 )
23         curl? ( >=net-misc/curl-7.18.2 )
24         doc? ( dev-qt/qthelp:4 )
25         jabber? ( net-libs/gloox )
26         webinterface? ( dev-qt/qtscript:4 )"
27 DEPEND="${RDEPEND}
28         nls? ( sys-devel/gettext )"
29
30 src_configure() {
31                 local mycmakeargs="
32                         $(cmake-utils_use_with bittorrent) \
33                         $(cmake-utils_use_with curl) \
34                         $(cmake-utils_use_with doc DOCUMENTATION) \
35                         $(cmake-utils_use_with jabber) \
36                         $(cmake-utils_use_with nls) \
37                         $(cmake-utils_use_with webinterface)"
38                 cmake-utils_src_configure
39 }
40
41 src_install() {
42         use bittorrent && echo "MimeType=application/x-bittorrent;" >> "${S}"/data/${PN}.desktop
43         cmake-utils_src_install
44 }
45
46 pkg_postinst() {
47         # this is a completely optional and NOT automagic dep
48         if ! has_version dev-libs/geoip; then
49                 elog "If you want the GeoIP support, then emerge dev-libs/geoip."
50         fi
51 }