]> Pileus Git - ~andy/sunrise/blob - net-libs/webkitgtk/webkitgtk-29438.ebuild
net-libs/webkitgtk: Nuke old and add a comment on bad autotools usage
[~andy/sunrise] / net-libs / webkitgtk / webkitgtk-29438.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit autotools
6
7 DESCRIPTION="Open source web browser engine"
8 HOMEPAGE="http://www.webkit.org/"
9 MY_P="WebKit-r${PV}"
10 SRC_URI="http://nightly.webkit.org/files/trunk/src/${MY_P}.tar.bz2"
11
12 LICENSE="LGPL-2 LGPL-2.1 BSD"
13 SLOT="0"
14 KEYWORDS="~x86 ~amd64"
15 IUSE="debug gstreamer sqlite svg"
16
17 S="${WORKDIR}/${MY_P}"
18
19 RDEPEND=">=x11-libs/gtk+-2.0
20         dev-libs/icu
21         >=net-misc/curl-7.15
22         media-libs/jpeg
23         media-libs/libpng
24         dev-libs/libxslt
25         dev-libs/libxml2
26         sqlite? ( >=dev-db/sqlite-3 )
27         gstreamer? (
28                 >=media-libs/gstreamer-0.10
29                 >=media-libs/gst-plugins-base-0.10
30                 >=gnome-base/gnome-vfs-2.0
31                 )"
32
33 DEPEND="${RDEPEND}
34         sys-devel/bison
35         dev-util/gperf
36         >=sys-devel/flex-2.5.33"
37
38 src_unpack() {
39         unpack ${A}
40         cd "${S}"
41
42         eautoreconf
43         # FIXME! do not call automake directly in ebuilds
44         automake --add-missing
45 }
46
47 src_compile() {
48         local myconf="$(use_enable sqlite database) \
49                         $(use_enable sqlite icon-database) \
50                         $(use_enable svg)
51                         $(use_enable debug)
52                         $(use_enable gstreamer video)"
53
54         econf ${myconf} || die "configure failed"
55
56         emake || die "emake failed"
57 }
58
59 src_install() {
60         emake DESTDIR="${D}" install || die "Install failed"
61 }