]> Pileus Git - ~andy/sunrise/blob - net-libs/ldns/ldns-1.5.1.ebuild
1379d5b46ef73404235eaaedcdcf823cc1a1eeeb
[~andy/sunrise] / net-libs / ldns / ldns-1.5.1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header$
4
5 DESCRIPTION="ldns is a library with the aim to simplify DNS programing in C"
6 HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
7 SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
8
9 LICENSE="BSD"
10 SLOT="0"
11 KEYWORDS="~amd64 ~x86"
12 IUSE="examples"
13
14 DEPEND="dev-libs/openssl"
15 RDEPEND=${DEPEND}
16
17 src_install() {
18         emake DESTDIR="${D}" install || die "emake install failed"
19         dodoc Changelog README || die "dodoc failed"
20
21         if use examples; then
22                 docinto examples
23                 dodoc examples/* || die "dodoc for examples failed"
24         fi
25 }
26
27 pkg_postinst() {
28         ewarn "The drill binary and the ldns-* utilities were moved into their own"
29         ewarn "package. If you need them, install net-dns/ldns-utils."
30 }