]> Pileus Git - ~andy/sunrise/blob - net-libs/gloox/gloox-0.9.3.ebuild
Remove pointless virtual/libc dependency, quoting
[~andy/sunrise] / net-libs / gloox / gloox-0.9.3.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
6 HOMEPAGE="http://camaya.net/gloox"
7 SRC_URI="http://camaya.net/download/${P}.tar.bz2"
8
9 LICENSE="GPL-2"
10
11 SLOT="0"
12 KEYWORDS="~x86"
13 IUSE="debug gnutls idn ssl zlib"
14
15 RDEPEND="idn? ( >=net-dns/libidn-0.5.0 )
16         gnutls? ( >=net-libs/gnutls-1.2.0 )
17         ssl? ( >=dev-libs/openssl-0.9.7 )
18         zlib? ( sys-libs/zlib )"
19
20 DEPEND="${RDEPEND}"
21
22 src_compile() {
23         econf \
24                 $(use_enable debug debug) \
25                 $(use_with idn libidn) \
26                 $(use_with gnutls gnutls) \
27                 $(use_with ssl openssl) \
28                 $(use_with zlib zlib) \
29                 || die "configure failed"
30         emake || die "emake failed"
31 }
32
33 src_install() {
34         emake DESTDIR="${D}" install || die "make install failed"
35 }