]> Pileus Git - ~andy/sunrise/blob - net-libs/fec/fec-1.0.3.ebuild
net-p2p/NativeThread: Add RDEPEND
[~andy/sunrise] / net-libs / fec / fec-1.0.3.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils flag-o-matic toolchain-funcs
6
7 DESCRIPTION="Forword error correction libs"
8 HOMEPAGE="http://www.onionnetworks.com/developers/"
9 SRC_URI="http://www.onionnetworks.com/downloads/${P}.zip"
10
11 LICENSE="BSD-2"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 RDEPEND=""
17 DEPEND="virtual/jdk
18         app-arch/unzip"
19 S=${WORKDIR}/${P}/src/csrc/
20
21 src_unpack() {
22         unpack ${A}
23         cd "${S}"
24         epatch "${FILESDIR}"/Makefile.patch
25 }
26
27 src_compile() {
28         append-flags -fPIC
29         tc-export CC
30         emake || die
31 }
32
33 src_install() {
34         into /opt/freenet
35         dolib.so ../../lib/fec-linux-x86/lib/linux/x86/libfec{8,16}.so
36 }