]> Pileus Git - ~andy/sunrise/blob - net-ftp/foff/foff-0.99.5.ebuild
sunrise/app-portage/overlay-utils/overlay-utils-0.2.ebuild: Update copyright headers...
[~andy/sunrise] / net-ftp / foff / foff-0.99.5.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils python multilib
6
7 DESCRIPTION="FTP client in Python and GTK."
8 HOMEPAGE="http://foff.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15 S=${WORKDIR}/${PN}
16
17 DEPEND=">=dev-lang/python-2.3
18         >=dev-python/pygtk-2.6"
19 RDEPEND="${DEPEND}"
20
21 src_install() {
22         # Copying.txt is needed by the about window
23         insinto "/usr/$(get_libdir)/${PN}"
24         doins *.py foff_logo00.png *.glade *.gladep Copying.txt
25
26         # The app needs to be executed from the installed dir
27         echo -e "#!/bin/bash \ncd "/usr/$(get_libdir)/${PN}" \n\
28 /usr/bin/python ${PN}.py" >> foff
29
30         dobin foff
31         dodoc Readme.txt ChangeLog.txt
32 }
33
34 pkg_postinst() {
35         python_mod_optimize "${ROOT}usr/$(get_libdir)/${PN}"
36 }
37
38 pkg_postrm() {
39         python_mod_cleanup "${ROOT}usr/$(get_libdir)/${PN}"
40 }