]> Pileus Git - ~andy/sunrise/blob - net-dialup/iwar/iwar-0.071.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / net-dialup / iwar / iwar-0.071.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="Intelligent Wardialer Program"
8 HOMEPAGE="http://www.softwink.com/iwar"
9 SRC_URI="http://softwink.com/iwar/download/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="iax2 mysql"
15
16 DEPEND="sys-libs/ncurses
17         mysql? ( dev-db/mysql )"
18 RDEPEND="${DEPEND}"
19
20 src_unpack() {
21         unpack ${A}
22         cd "${S}"
23         EPATCH_SOURCE="${FILESDIR}"
24         EPATCH_SUFFIX="patch"
25         EPATCH_FORCE="yes" epatch
26 }
27
28 src_compile() {
29         econf $(use_enable mysql) \
30                 $(use_enable iax2)
31
32         emake || die "emake failed"
33 }
34
35 src_install() {
36         dodir /etc/iwar
37                 emake DESTDIR="${D}" install || die "Install failed"
38                 dodoc AUTHORS ChangeLog FAQ MODEMS-TESTED README README.IAX2 THANKS TODO
39                 doman "${FILESDIR}"/${PN}.1
40 }
41
42 pkg_postinst() {
43         elog "Users must be in group uucp in order to be able to use iwar."
44 }